Please note: The forum is now closed to new submissions. All the existing forum topics and posts are still available, however new topics cannot be created. If you need Sinclair C5 advice please use the C5 Owners Facebook Group.

derekw posted:

Hi, any help appreciated.
Left hand pod leds flash when turned on, with no power to motor.
Have fitted another pod which works OK so no problem with motor or control box.
Have fitted pod to another C5 and does the same thing.

thanks Derek
posted on: 15/03/2014 11:33:16

kamztrad posted:

Hi Derek, posted this very same problem a few weeks ago under help wanted - Dan advised it was probably the LM358 op amp on the control box PCB - I replaced this part by removing it and soldering in a IC socket and fitting a new LM358 (fitted socket so easier to replace if happens again) - this cured the flashing LED's on the left hand side - I had tried another POD and still had problem before I changed the op amp as per Dan's advice.

I also did the PCB mod to change the LM358 power supply from 12v to 5v and the Perran Newman (POD designer) mod to protect against transients in the POD and help protect the ULA - as per the previous post.

All this info is in the previous post by me and Dan's advice and references are in there.


posted on: 15/03/2014 12:25:56

Dan posted:

Hi Derek,

So you say the POD works on another C5? If so it's the control box. As kamztrad said it could be the op amp chip.  Check the fuses too.

The control box mod (12V to 5V) and the Perran Newman POD mod are both highly recommended, especially the POD mod as it may well save your ULA chip and we all know how expensive those are to replace.
posted on: 15/03/2014 13:27:48

derekw posted:

Hi, thanks for replys, I have read previous flashing led posts, but they are different to mine.
The pod leds on left side flash. have tried on other C5 and they still flash. with no power to motor,
Put another pod on this C5 and works OK.
So this would suggest a problem with the pod, as both control box and motor work ok with another pod.
posted on: 16/03/2014 14:17:02

Dan posted:

I'd suspect the ULA chip is the problem then, you could check the Red cable connector in the POD for dry joints, but this looks like the ULA is at fault to me. The only way to know for sure is to swap ULA chips in the pod, but be careful if you do this as they're sensitive to static.
posted on: 16/03/2014 20:13:06