Please note: The forum is now closed to new submissions. All the existing forum topics and posts are still available, however new topics cannot be created. If you need Sinclair C5 advice please use the C5 Owners Facebook Group.

AndyH posted:

Hi Everyone,

I finally bought a C5 after wanting once since they were launched back in 1985! Mine is a barn find and has never been used so I was gutted when I fitted a new battery and, whilst the front & rear lights worked, there is no life in the pod or motor :(

I have cleaned all the contacts but thats as far as my technical ability gets. If anyone can advise on what I should check next it would be very much appreciated as I'd love to get it running again.

posted on: 29/08/2015 19:54:34


Hi Andy first of all check if the motor runs by connecting it directly to a battery ,but make sure that the wheels are off the ground first ...

Bye Chas
posted on: 29/08/2015 22:09:54

AndyH posted:

Hey Chas, thanks for getting back to me so quickly!

So I tried that and initially it was dead, but wiggling the contacts on the motor brought it back to life so the motor seems fine. I then tried connecting the battery directly to the original keyswitch to make sure the contacts weren't a problem at that end (observing correct polarity so as not to blow it up) but still no pod lights and no motor action when I press the handlebar switch ... any ideas what to check next would be much appreciated.

Thanks again.
posted on: 30/08/2015 13:21:21