Please note: The forum is now closed to new submissions. All the existing forum topics and posts are still available, however new topics cannot be created. If you need Sinclair C5 advice please use the C5 Owners Facebook Group.

C5mick posted:

Another control box problem.

Nothing at all worked on this control box before I started testing it.

I found R1 2.2 ohm resistor burnt out, now replaced for new 1/4 watt
D1 IN5401 not working, replaced for new
TR3 transistor ZTX449 also replaced just because had a lot of trouble with his on other control boxes

Pod lights now work

When motor power button is pressed there is still no power to the motor and the green light on the pod doesn't illuminate

There is 12V to X8 pin 5 when battery connected
When motor power switch is pressed there is 12v to X8 pin6

There is no voltage to X12 or X13

Any suggestions please..

posted on: 24/01/2015 16:10:39

Karl posted:

At Mick's request we delved into yet another problem CB board.

It boiled down to a dry joint on X8, pin 6, the motor switch return line.

So I believe that all of Mick's boards are now up and running.

At this rate Mick will be the new CB problem expert.
posted on: 24/01/2015 19:00:32

C5mick posted:

Hi Karl
Lol, I don't think that I have solved too many problems, I have had loads of help, pointers and parts sent to me to help me to repair six control boxes. I have been educated along the way and I now have a better understanding of the control box.
Thanks Karl, Chas and Marty
posted on: 24/01/2015 19:10:00