Please note: The forum is now closed to new submissions. All the existing forum topics and posts are still available, however new topics cannot be created. If you need Sinclair C5 advice please use the C5 Owners Facebook Group.

Ray1 posted:

A week ago when I first connected the POD & control box on my 2nd C5 there were no lights initially. Checking around the control box with my multi-meter I seemed to be getting 20 to 24 volts. (Is it possible for a standard 12 volt battery to be stepped up by the control box or POD?
After a time of turning all off, re-connecting and testing I eventually got all lights on the POD.
After more time wriggling the POD connector etc. I eventually got the battery lights plus the outer amber motor lights. At this stage the motor would run and has done so with the C5 on the workbench for the last few days.
I had to run the motor without the micro-switch which was stuck and have replaced that today and moved onto fixing the front & rear lights, removed the old bulbs and have to get 2 new ones.
I now find I am back to no POD lights and measuring 20 to 24 volt again. The POD is ok on the other C%.
Any clues what to look at please?
posted on: 15/04/2014 16:04:54

Poze posted:


Not sure if this is related, but quite a common issue relating to Pod lights is to do with the loom connector for the back of the pod.

I have had this issue over the last week with the pod flickering or just not working. Basically the connector on the end of the red wire loom was crap, probably corrosion/worn, so i ran my home made test loom from the control box to the pod and it lit perfectly.

So I got hold of another "connector" (they use the same design on laptops/pcs), then basically pulled each red wire of the old connecor and pressed them into the new connector (one at a time to keep the order). Did them all, reconnected to the back of the pod and it worked/lit perfect.

The new laptop connectors are almost the same shape, but work perfectly with the pod. The red wires just push into the connector (using a small screwdriver) and basically splice themselves to make a connection, so no solder is needed, just push them in.

Might help.

posted on: 15/04/2014 20:46:01

Ray1 posted:

Thank you for the suggestion Poze, I had to go through that learning curve with my first C5 and this is something different.

I have an update:
Today I pulled all connectors off and after a few tries putting them back I got the motor working again. No clue how or why though. Possibly poor connection other than at the POD?
After that as usual I had to wiggle the red POD connector to get lights working correctly. Now short road tested, needs a front bulb, the control box cover fitting and it's ready for the grandchildren to race me on. Sneakily I have only fitted a used car battery I had so I SHOULD be faster, excess weight permitting!!!

posted on: 16/04/2014 16:34:08