Please note: The forum is now closed to new submissions. All the existing forum topics and posts are still available, however new topics cannot be created. If you need Sinclair C5 advice please use the C5 Owners Facebook Group.

iaccaloco posted:

Hello to ya'll out there!

I'm Japie, 37 y.o. and i live in The Netherlands nearby Amsterdam.

I am self-employed at my own small bicycleshop.

Recently i bought my first C5 after years of looking and searching for one.
(It was an little issue from my childhood, some kid had one, had to have one, but it took me allmost 30 years....;) )

My C5 is as good as new, i'm the second owner(the seller not mentioned)

Everything is(was!) in a nice good condition.

First some pix:
[img=]My C5![/img]
[img=]My C5![/img]

I haven't got the original batterypack and charger.

No probs for so far....

After attaching a battery for the first electric test i think i must have made a mistake wiring up the battery.

Think i switched the + and - poles.... :( *STOOOOPID!!!*

What can i expect?

I was just about to take it out for the first electric testride but it does'nt work anymore.

After attaching the batt. for the first time everything worked fine.
The LED-bar in the dashboard and the motor, the ligths etc.

Please tell me, did i screwed it up BIGGG! time, or is there somewhere a fuse that i can replace?
I hope you like the C5 and hope anyone can give me some tips of what to do because i really want to use it with the electric motor....

Greetings from the Netherlands...;)

posted on: 29/10/2013 12:49:22

Dan posted:

Welcome to the website Japie

It sure looks in good condition your C5.

It may be bad news if you've connected the battery terminals the wrong way around, I've not got a C5 with the original wiring yet so can't say how you'd go about fixing it, but I'm sure other members will be along to help soon!

It may be the control box has been damaged.  You're first investment should really be a safety wiring kit to prevent a similar problem in the future, Chas sells them on ebay if you want one.
posted on: 29/10/2013 13:21:34


Hi there welcome to the forum .It looks you have a great and well looked after C5
Regarding the problem you may have blown the 12v to 5 volt regulator it's the 3 pin chip that has the heat sink under it .It's the first thing I would test for ..
Bye Chas
posted on: 29/10/2013 17:59:21

Dan posted:

Ah the regulator, yep if you need one I've got a box of them.  You can have one for free if you pay the postage...
posted on: 29/10/2013 18:04:44

iaccaloco posted:

Thanks for the welcome, and Dan, i've replied your PM!

Thnxx for so far!

posted on: 29/10/2013 18:22:37

Dan posted:

Hi iaccaloco,

I've just posted your control box back to you.  The regulator was dead and resistor R1 burnt out, so have replaced both of those and also the connector X5.  I tested it on one of my C5's (having put the POD and original wiring back on it), and it works great.  Let us know how you get on with it
posted on: 05/11/2013 13:43:50

iaccaloco posted:

Hi Dan!

The package is arrived.

I don't think i can find the time today to mount the unit again, but as soon as its attached again i'll immediately let you know how it works!!

Many many many thanks in advance for your kindness,

Did you tried the bottle already? :)

(PS, thanks for the CD, my CDrom is'nt working but i'll try it on a stereo soon)

posted on: 09/11/2013 09:47:38

Dan posted:

Hi Japie,

Glad it got to you okay.  I've tried some of the "De Kater", you're right it is strong stuff.  Very nice though, thanks for sending it

Enjoy the CD, the music video for it is here:

Some very amusing Clive Sinclair/C5 stuff in it
posted on: 10/11/2013 14:34:19

iaccaloco posted:

[quote=Dan;1772]Hi Japie,

Glad it got to you okay.  I've tried some of the "De Kater", you're right it is strong stuff.  Very nice though, thanks for sending it

Enjoy the CD, the music video for it is here:

Some very amusing Clive Sinclair/C5 stuff in it[/quote] Hi Dan(and the others:) ) Today i've remounted the unit again...... Guess what....?! It's not working...:( The only thing working are the head- and taillight when i wire up the battery. Both of the sides(wires) for the battery are not responding, also the POD won't light up.... Do you know what i could do now? I think imo there's some other part that i blew up.... :'( Hope to hear from you, Greetings, Japie!
posted on: 16/11/2013 13:45:12

Janhein posted:

If you are really stuck with it, You can give it a try at the Fablab denhaag.

I work there as a volunteer and we have an electronics expert in the house.
He used to have some C5´s in the past and I think he can help you further if nothing else works.

You can tell them i have send you. succeeds with your project.

posted on: 16/11/2013 14:39:10

dadandjames posted:

Think it is time to get the multimeter out. It is probably abasic conection somewhere. Does the relay click?
Is the switch on the handle bar wired properly to the place on the board?
Good fun looking.
posted on: 16/11/2013 16:13:15

Dan posted:

Hi Japie,

Are you able to check the pod? Another member also connected the battery the wrong way around and the pod was damaged as well as the control box. So the first thing you should do is check the pod circuit board, see if there is any visible damage to any of the components.

posted on: 16/11/2013 17:00:10