Please note: The forum is now closed to new submissions. All the existing forum topics and posts are still available, however new topics cannot be created. If you need Sinclair C5 advice please use the C5 Owners Facebook Group.

mhorst03 posted:

Hi Want to introduce myself, I'm Marco from the Netherlands, and i'm the proud owner of a Sinclair C5 since last week. Hope to find some tips/tricks and parts for my new hobby.
posted on: 11/08/2014 08:42:31

SINCLAIR C5 CHAS posted:

Hi there welcome to the forum Chas
posted on: 11/08/2014 16:49:26

Area51 posted:

Hi there welcome to the forum and you have a nice C5
posted on: 11/08/2014 17:52:59

Dan posted:

Hi and welcome to the website. If you need any help let us know
posted on: 11/08/2014 20:12:25

andries.moss posted:

Hallo Mooi auto ;-)
posted on: 17/08/2014 10:54:44

mhorst03 posted:

Hi, Got myself a problem. I was riding home when the engine stopped. I've got power, lights are working. No display and no engine. I replaced both fuses, but that does not help. Any idea's or tips? I'm about to meassure tonight if i get any power on the engine, don't know that yet. Hope you can help me out here! many thanks
posted on: 04/09/2014 10:34:53

SINCLAIR C5 CHAS posted:

Hi there what you could do First thing is to jack up the c5 then disconnect the Motor leads and connect them to the battery and see if the motor is ok Bye Chas
posted on: 04/09/2014 11:36:42

mhorst03 posted:

Hi Meassured the engine. it seems the engine is not getting power haven't tried the engine on the battery yet....
posted on: 07/09/2014 09:16:03

SINCLAIR C5 CHAS posted:

Hi you need to test the motor direct on the battery Chas
posted on: 07/09/2014 09:23:36